Back to overview
Resolved
Network Maintenance
Sep 1, 2026 at 1:26am UTC
–
Sep 1, 2026 at 1:45am UTC
Affected services
NSAO Remote Support Desktop Website
NSAO Cloud Desktop
Resolved
Sep 1, 2026 at 1:45am UTC
Maintenance ended
Affected services
Created
Sep 1, 2026 at 1:26am UTC
Network maintenance
Affected services