Back to overview
Resolved

Microsoft Exchange Online Outage Authentication Failures and Email Delays Impacting Thousands

Aug 31, 2026 at 6:59pm UTC
Affected services
Manually tracked item

Resolved
Sep 1, 2026 at 1:25am UTC

Service restored

Created
Aug 31, 2026 at 6:59pm UTC

Microsoft Exchange Online Outage Authentication Failures and Email Delays Impacting Thousands

https://www.nsao.com/post/microsoft-exchange-online-outage-authentication-failures-and-email-delays-impacting-thousands